Sound delay

After more than one year, our nanit cam started showing a delay between video and sound. Android app starts in sync, but the delay starts growing and after some time of monitoring we have a few minutes of delay in the sound. Must restart the app to regain sync. Anyone else has this?

Best Answer

  • NanitChristopher
    NanitChristopher Nanit Support Team
    Answer ✓

    Hi @Randrade @BabyThor @Delafish_03 @nconkl1,


    I have good news! Our team has deployed a fix. Please go to the Google Play Store and update the Nanit App to 3.3.10.5. If you continue to experience an audio delay after this update please let our team know.

Answers

  • Yes this has been happening to me for the last week! and its on all devices so is definitely an issue with Nanit. When we leave it on overnight, the sound delay builds up to approx. 10 mins by morning. The camera is still up to date but the sound is not. I have tried restarting the camera itself, reinstalling the app and nothing is working.

  • NanitJessica
    NanitJessica Community Moderator, Nanit Team

    Hi @Randrade,

    Thanks for posting on the community. We'll be happy to assist with you further with your Nanit camera experiencing some delay with your video and sound. What Android OS version are you on and what app version are you running? Is this also happening when you're on WiFi and/or cellular data? We would also recommend you to try power cycling your router to see if that helps.

    Hey @BabyThor,

    Thanks for letting us know you're also experiencing this issue. What phone device are you using? What OS version is your phone device on? And is this happening when you're on WiFi and/or cellular data? Also, we recommend for you to try power cycling your router to see if that helps.

  • This is happening to me as well. I have the most updated version of the app and my phone just updated and I am also experiencing the same issue. We have had the app for over a year. I have had the same phone and internet services and I am experiencing extremely delayed sound. Does Nanit have a plan of action to solve this or look into options.

  • NanitJessica
    NanitJessica Community Moderator, Nanit Team

    Hi @Delafish_03,

    We appreciate you sharing your concern about this issue. Try power cycling your router to see if that will help your issue. Also, try restarting your phone device to see if that helps.

    If you're still experiencing the problem, please answer the following questions below as it will help us assist you better:

    • What phone device are you using? What OS version is your phone device on?
    • Is this happening when you're on WiFi and/or cellular data?
  • NanitChristopher
    NanitChristopher Nanit Support Team

    Hi @Randrade @BabyThor @Delafish_03,

    This is Christopher; I'm a senior tech at Nanit Support. Thank you for sharing this issue to our community form. Our team has started investigating this bug. I wanted to ask, after performing the troubleshooting provide, has anyone continued to experience the issue with the audio delay? If you have, can we work with you to find a solution? If you're willing to work with our team, please let me know, and we'll open a support ticket with you.

  • nconkl1
    nconkl1 Member
    edited March 4

    I've noticed this has started happening to me as well, I think. I only know something is wrong because I'll set the camera and by morning there's about a 30 second to 1 minute delay (this could actually be more but anything other than the half a second is unacceptable) between what's actually going on in my daughter's room and what I'm seeing and hearing on my device. She had clearly woken up the other morning and was standing up in her crib but the app still showed her as laying down asleep.

    The app is on it's latest version (Firmware 23.1.6) and this happens while on a stable wifi connection. I have a Gigabit connection and download speeds of ~300 Mbps with the same upload, 2 Ms ping and 0 jitter from a recent Speed Test. The app shows full connection. And judging from recent Google Play Store reviews, this is a known issue but here's my phone specs anyway

    There doesn't seem to be a way to enable logging or debug mode on the app that's visible to the user but if Support has a way to enable something like that, I'd be interested in knowing how so I can upload logs. Can anyone from Support confirm if there is an open JIRA (or ticket with the developers/engineers) on this yet?

  • NanitMackenzie
    NanitMackenzie Community Moderator, Nanit Team

    @nconkl1 - thank you so much for sharing all of this information with us! Our team is investigating this bug currently as @NanitChristopher mentioned above.

    I've opened up a support ticket with our team - Christopher will reach out to you directly to work with you to find a solution - hopefully we can get to a resolution for you and other users affected as quickly as possible. He will be in touch soon. Thank you again!

  • NanitJessica
    NanitJessica Community Moderator, Nanit Team

    We like to provide an update to everyone that our development team has identified the issue and the fix is being tested. This fix should be coming on the next Android app update, which should be rolling out by next week.

    We appreciate everyone's patience and will update the community when the app version has been released on the Google Play Store!

  • NanitChristopher
    NanitChristopher Nanit Support Team
    Answer ✓

    Hi @Randrade @BabyThor @Delafish_03 @nconkl1,


    I have good news! Our team has deployed a fix. Please go to the Google Play Store and update the Nanit App to 3.3.10.5. If you continue to experience an audio delay after this update please let our team know.