Camera suddenly won't turn on

It's been almost two years since I got my Nanit Plus, however, lately it has been losing connection every single day. There's no problem with the internet, camera is 1,5 meters away from router, just a door away, and this morning it disconnected completely and made me troubleshoot connect it again, but flash light wouldn't turn on, wouldn't work. I had to re-start it and detach, still it hasn't turned back on again.. I've tried taking out of the electrical socket and back in again, nothing.. tried everything possible. Please help.

Best Answer

  • Melanie
    Melanie Nanit Team
    Accepted Answer

    @Carol_Romagnoli01 Thank you for posting here - it sounds like you've done a ton of troubleshooting, so I want to have a member of our support team take a closer look at your camera so we can get a quick resolution. I've escalated this over to them and they will be reaching out to you via email to troubleshoot further.

Answers

  • Thank you, Melanie. Indeed two of them have. Problem has been fixed.

  • It turns on, however, this keeps happening many times a day.

  • Melanie
    Melanie Nanit Team

    @Carol_Romagnoli01 sorry for my delay here! I know you've been in touch with our support team and I see they have a note out to you for next steps.

  • Meganb
    Meganb Member

    Same situation, same issue! Would love to use this very expensive camera for the purpose I bought it for! Getting very frustrated...

  • Melanie
    Melanie Nanit Team

    @Meganb I apologize you have been having connectivity issues with your camera - since it sounds like this problem has been reoccurring for you, I've escalated this over to our support team so they can troubleshoot with you directly and resolve this as quickly as possible.

  • I’m having the same issue as well. My nanit just stop working and wouldn’t turn on. I’ve try resetting with no luck

  • @Melanie seeking your help / escalation as well due to same issue. I’ve tried all troubleshooting as you suggested in a related thread, but to no avail. Please help!

  • Hi there,

    same issue here! Plugged in but no camera - have troubleshooted every way mentioned. Hear clicking but no video stream.

    please advise.

    thanks!

  • Timi
    Timi Member

    Same is happening with us, the connection is ok but still the camera keeps disconnecting and the music can not be turned on. This happened to us all night for a week now. Could you please help?

  • @Melanie good evening. I am having the same issue and have tried all the troubleshooting as well. Can you please have the Support team reach out to me as well.

  • We are having the same issue! We’ve only had the camera 2 days so very disappointing. None of the trouble shoot options make any difference. Some help would be great.

  • I am in this exact same boat, we’ve only had this camera for about a week and now have been up since 1am trying to figure it out why exactly this issue is happening.. this camera is brand new.. and not cheap may I add. Really disappointed to even have to be dealing with this.

  • Soup
    Soup Member

    I have had my pro camera for three days and now it will not turn on. It is very warm to the touch. I think something is defective and it burned out - very disappointed given the $500+ I spent on this thing.

  • Soup
    Soup Member

    I have sent two emails to Nannit support and no one is getting back to me. Is there a phone number I can call to talk to a human? I am so disappointed in the faulty hardware and lack of support - especially when I have no baby monitor right now.

  • Soup
    Soup Member

    @Carol_Romagnoli01 if possible, could you share how technical support helped you get the Nanit camera to power back on? I have troubleshooted based on posts in the community and have had no luck. I have also tried and tried to contact Nanit support but no one gets back to me :(

  • katiempa
    katiempa Unconfirmed, Member

    the same thing is happening with my brand new Nanit. Can someone let me know what ended up being the problem and how to fix it?

  • Tanya9
    Tanya9 Member
    edited September 11

    I am having the same exact issue. I have twins and two sets of cameras. One of the cameras works great and funny enough it happens to be the camera furthest away from the router. The other camera however has had connectivity issues ever since I purchased it and then today the power went out completely. I tried restarting the camera several times, and plugging it into a different outlet, but unfortunately none of the troubleshooting has worked. I'm thankful that the 2nd camera and breathing monitor is still working so I can still hear any noises coming from the nursery. Unfortunately though the camera and monitor that isn't working is for the smaller of my two twins and the one that I am overly concerned about monitoring her breathing due to her size. Could you please assist me?